VPLS(虛擬專用 LAN 服務)透過 MPLS 主幹連線多個地理位置不同的站點,因此它們都充當單個第 2 層網路。不同位置的裝置可以像插入同一交換機一樣進行通訊。

VPLS 的工作原理

傳統 VPN 在第 3 層執行 - 它們在站點之間路由 IP 資料包。 VPLS 工作在第 2 層,轉發乙太網幀。提供商的 MPLS 網路充當巨型虛擬交換機。

核心元件:

  • CE(客戶邊緣): 每個站點的路由器或交換機
  • PE(提供商邊緣): 連線到您站點的 ISP 具有 MPLS 功能的路由器
  • P(提供商核心): 承載流量的內部 MPLS 路由器

每個 PE 路由器維護每個 VPLS 例項的 MAC 地址表。當幀從 CE 到達時,PE 查詢目標 MAC,將幀封裝在 MPLS 標籤堆疊中,然後透過核心將其轉發到正確的遠端 PE - 剝離標籤並將原始乙太網幀傳送到目標 CE。

未知的 MAC 會觸發對 VPLS 例項中所有 PE 節點的洪泛,就像真實的交換機會洪泛未知的單播流量一樣。

VPLS 與其他 WAN 技術

特點 VPLS MPLS L3VPN VXLAN
層 L2 L3 L2 優於 L3
需要路由 沒有 是的 沒有
廣播域 共享 分開 共享
可擴充套件性 限量 高 高
典型用途 區域網擴充套件 站點互連 資料中心覆蓋

兩種 VPLS 信令標準

RFC 4761(基於 BGP): PE 路由器使用 BGP 自動發現對等體並分發標籤。擴充套件性更好,手動配置更少。

RFC 4762(基於 LDP): PE 路由器使用 LDP 在每個 PE 對之間傳送偽線訊號。更簡單,但需要全網狀偽線配置 - 對於許多站點來說,很快就會變得複雜。

大多數企業部署將基於 BGP 的 VPLS 用於超過三個或四個站點的任何情況。

VPLS 的應用場景

  • 連線執行二層協議的分支機構(VPLS透傳STP、CDP、LLDP)
  • 在 VXLAN 成為標準之前跨資料中心擴充套件 VLAN
  • ISP 作為透明 LAN 服務 (TLS) 出售的運營商乙太網服務
  • 需要伺服器之間第 2 層鄰接的遺留應用程式

需要了解的限制

所有站點的廣播流量氾濫 - 不良設計或某一位置的廣播風暴會影響 VPLS 例項中的每個站點。 MAC表的刻度也是一個值得關注的問題;具有許多端點的大型部署可能會壓垮 PE 路由器。 EVPN (RFC 7432) 在現代部署中很大程度上取代了 VPLS,因為它透過 BGP 控制平面而不是資料平面泛洪處理 MAC 學習。

底線

當您需要站點之間真正的第 2 層連線並且您的提供商執行 MPLS 時,VPLS 是正確的工具。它透明、靈活且受到廣泛支援,但它不像 EVPN 那樣可擴充套件,並且廣播密集的環境可能會導致問題。如果您正在設計新產品,請首先評估 EVPN;對於現有部署和遺留環境,VPLS 仍然值得了解。